Variáveis de Apresentação – Definindo “Todas as Opções” como padrão em uma analise

Publicado: 09/12/2015 por Felipe Idalgo em Ambiente/Infraestrutura

Ola Pessoal, tudo bom?

Hoje trago uma dica bastante simples porém muito utilizada no processo de desenvolvimento utilizando a suíte OBIEE.

As variáveis de apresentação foram concebidas para funcionarem em escopo de painel, ou seja, somente conseguimos atribuir um valor a este objeto através de um painel (como por exemplo através de um prompt de painel).

Quando construímos uma analise e temos a necessidade de utilizar estas variáveis normalmente definimos um valor padrão para a variável que somente é substituído quando populamos esta variável mapeada no relatório em escopo de painel.

Isto pode se tornar um problema quando esquecemos de definir um valor padrão em nosso prompt de painel ou quando não deve existir um valor padrão, pois a analise será filtrada pelo valor default que você associou a variável dentro de sua análise.

Para contornar isso trouxe hoje uma dica bastante simples. Ao invés de você utilizar um valor padrão válido, utilize o “%”, ele garantirá que todos os resultados para aquela coluna serão retornados caso a variável de apresentação não seja populada com um valor específico.

Qualquer dúvida estou a disposição

Abraços

Felipe Idalgo

 

Anúncios
comentários
  1. ferrerlambert disse:

    Oi Felipe, tudo bem?

    Talvez consiga me ajudar numa situação.

    Seguinte, preciso construir um gráfico onde possuo duas medidas: valor1 e valor 2, onde valor1 recebe todos os filtros aplicados
    pelos usuários nos prompts (painel) e valor2 recebe apenas o filtro de tempo. A intenção é fazer um comparativo entre as medidas.

    Já realizei vários testes, segue conclusão:

    1. Utilizando UNION funciona, mas é lento e não me parece uma boa solução
    2. Utilizando os filtros dentro da fórmula da coluna:
    2.1 Se o valor default do prompt é “todos os valores de coluna” só funcionará quando o usuário selecionar especificamente alguma opção (mesmo que eu utilize o “IN”) – por curiosidade, para que saibam, isso ocorre porque o OBIEE envia para o banco a requisiçaõ de “todos os valores de coluna” literalmente
    2.2 Se eu configuro para que não haja valor default no prompt, ele apresenta os dados do filtro aplicado na fórmula da coluna (answers) e só permite a escolha de uma opção no prompt de painel, ou seja, também não me atende.
    3. Utilizando o “%” como você sugeriu, na seção de filtros funciona, mas na fórmula da coluna não.

    Pelo que percebi o OBIEE concatena todas as opções selecionadas no prompt pelo usuário como se fosse 1 só e se perde.

    Obrigada (:

    • Felipe Idalgo disse:

      Oi Mel, tudo bem sim e você como esta?

      Teoricamente, em sua analise se você definisse o valor padrão de sua variável de apresentação como ‘%’ e em seu prompt não definisse valor ou selecionasse “todos os valores”, o OBI deveria NÃO incluir este filtro na analise.

      Estou sem acesso a um ambiente OBI agora, a noite vou fazer um teste e atualizo o comments.

      Té mais

      • ferrerlambert disse:

        Valeu Fe por ter respondido rápido.
        O meu problema é que o usuário pode selecionar mais de uma opção no prompt e quando isso acontece, minha análise retorna “sem resultados”.

        A fórmula para teste está bem simples:

        FILTER(“Medidas”.”Vlr. Liquidado” USING (“Gestão Orçamentária”.”Poder” = ‘@{vPoder}{%}’ and “Tempo”.”Ano” = @{vAno}{2015}))

  2. Letícia disse:

    Olá Felipe,

    tudo bem?

    Estou com uma dúvida e queria ver se você sabe me ajudar.

    Você saberia me dizer como faço para incorporar imagem dentro do OBIEE.

    Já procurei em vários lugares na internet mas não achei um lugar nenhum.
    Se você tivesse algum tutorial ensinando me ajudaria e muito.

    Obrigada.

    • Felipe Idalgo disse:

      Ola Leticia, tudo bem?

      No processo de mapeamento de arquivos e imagens no OBIEE nunca o estilo padrão da ferramenta deve ser alterado.

      Você deverá implantar um diretório compartilhado no WLS e depois disponibilizar suas imagens lá dentro. A partir dele pode utilizar suas imagens em analises, paineis e etc.

      Siga este tutorial:
      https://obieebrasil.wordpress.com/2012/04/09/disponibilizando-um-diretorio-no-weblogic-server/

      ***note que o diretório padrão de compartilhamento é o analyticsRes e você deve sempre utilizar o caminho absoluto em seus objetos.

      Ex.: se tiver disponibilizado um imagem no analyticsRes chamada LOGO.JPG para mapea-la em seus objetos, use: “/analyticsRes/LOGO.PNG” isso garantirá que caso você migre seu projeto para um outro servidor não precisa alterar o caminho das imagens utilizadas.

      Qualquer dúvida estou a disposição

      Abs

    • Olá Filipe, muito obrigado pelo excelente canal que disponibiliza para os profissionais que trabalham com o OBIEE.

      Bom Leticia, com o Felipe tinha informado, você poderá utilizar as pastas do analyticsRes, porém ao mudar a versão do OBIEE você caba correndo o risco de perder alguma imagem, além de ser uma customização na propria Ferramenta.

      Não sei como está instalado o seu ambiente, porém o servidor deverá ter o Oracle HTTP Server (OHS) configurado, assim sugiro criar uma pasta no OHS e acessá-la pelo OBIEE, utilizo essa solução a um bom tempo e funciona Bem!

      Att,

      • Felipe Idalgo disse:

        Ola Vinicius, tudo bom? a solução de utilização do shared folder pelo WLS é uma boa prática de utilização do OBIEE, o que não é recomendado é que façamos as alterações diretamente no stilo/skin padrões (core files), precisamos criar um custom. Recentemente fiz uma migração do OBI 11 para o 12 e neste caso os estilos custom nao funcionam, a solução adotada e documentada na Oracle foi a alteração do analytics.ear para inclusão de minhas pastas de estilo. Abs

  3. Letícia disse:

    Olá Felipe e Vinícius.

    Muito obrigada pela ajuda. Foi muito útil.
    Porém encontrei um probleminha.

    Inseri a minha imagem conforme instruções. E adicionei ela em um painel dentro do OBIEE.

    O endereço dela ficou: http://hostname:9704/analyticsRes/sk_blafp/b_mozilla_4/Atencao%20-%20Vermelho2.png

    Porém, quando vou exportar o painel em PDF imprimível a imagem não aparece.
    Vocês sabem porque isso ocorre? Tem alguma solução para que ela apareça?

    Desde já muito obrigada.

    Atte.,

    Letícia

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s